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AGENDA

• Materi Pertemuan #9: Menggunakan Teknik
Audit Berbantuan Komputer dalam
pengujian pengendalian dan pengujian
substantif
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Key objectives:

1. memahami kerangka konsep audit tata kelola teknologi informasi berdasarkan standar

tata Kelola

2. menyusun program audit tata kelola sistem informasi

3. menyusun laporan audit tata kelola sistem informasi

4. melaksanakan pengauditan atas pengoperasian dan pemeliharaan atas sistem informasi

5. melakukan audit atas perolehan, pengembangan, dan implementasi sistem informasi

6. melakukan pengauditan atas keamanan informasi

7. menggunakan Teknik Audit Berbantuan Komputer dalam pengujian pengendalian dan 

pengujian substantif

8. menjelaskan dampak kelemahan pengendalian umum dan pengendalian aplikasi

terhadap peluang terjadinya kecurangan dan kesalahan saji pada laporan keuangan

Here we are
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Teknik Audit Berbantuan Komputer
(CAATs)
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Audit Sistem Informasi

CAATs Definition

• Computer-Assisted Audit Techniques (CAATs) are the use of 
technology—ranging from basic spreadsheets to advanced data 
analytics software—to perform audit procedures more 
efficiently, accurately, and comprehensively than manual 
methods allow.
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Manual vs. CAATs
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Audit Activity Manual Audit CAATs

Data Selection
Sampling: Selecting 25–50 random 
vouchers to represent the whole.

Full Population: Testing 100% of the 
transactions in the database.

Mathematical Accuracy
Footing/Cross-footing: Adding up 
columns on a paper ledger by hand.

Automated Re-calculation: Instant 
verification via script.

Verification
Vouching: Manually matching an 
invoice to a shipping document.

Electronic Matching: Automated 
Matching using Computer.

Fraud Detection
Scanning: Looking for anomalies by 
flipping through pages.

Anomaly Detection: Using Benford’s 
Law or Gap Analysis to find outliers.

Cut-off Testing
Inspection: Checking the last few 
dates in the physical ledger at year-
end.

Time-Stamp Analysis: Analyzing
transaction logs to find "backdated" 
entries.
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Sample use of CAATs

• A District Government has a policy that any procurement above Rp.200 Million must go through a 

Public Open Tender. Anything below that can be a "Direct Appointment." You suspect a Project 

Manager is splitting a Rp.600 Million project into five Rp.120 Million contracts to give them to a 

friend’s company without a bid.

• Using CAATs, you discover that on the same day, Vendor A, Vendor B, and Vendor C each received a 

contract for Rp.120 Million for "Software Maintenance."

o Manual Audit would miss this because they might only sample one of these invoices.

o CAATs flags this immediately because it sees the total pattern across the entire database.
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Data Aquisition
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User

System Auditor

Extract Data Request
(CSV/JSON)

Database Connection
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CAATs Software
1. Spreadsheet (Microsoft Excel, Lotus 123)

2. Query & Reporting Application (Power Query, Crystal 
Reports)

3. Database Management System / DBMS (Microsoft Access, 
MySQL)

4. Generalized Audit Software / GAS (ACL, IDEA, Arbutus)
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Mengimpor
Data ke MS 
Excel
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Common File Formats 
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•Delimited Text (.csv, .txt): Data separated by specific 

characters (comma, semicolon, or tab).

•Database Files (.dbf, .mdb, .accdb): Structured data files 

from legacy systems (DBF) or Microsoft Access 

(MDB/ACCDB).

•JSON (.json): A modern, lightweight format used for web-

based applications and APIs.



Kesalahan Ketika Import Data
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Kesalahan saat impor data bisa menyebabkan kesalahan pengambilan

kesimpulan. 

1. Data Type Mismatch

Angka akun (00123) terbaca sebagai angka (123), sehingga angka nol

di depan hilang. Ini fatal untuk pencocokan (vlookup).

2. Date Format

Perbedaan format MM/DD/YYYY dan DD/MM/YYYY yang 

menyebabkan kesalahan perhitungan umur piutang (aging).

3. Truncation

Data terpotong karena panjang karakter melampaui limit kolom.



Praktik
Mengimpor Data 
ke MS Excel
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Lingkup Impor Data

• Delimited

• Fixed Width

• Mdb (Access)

• Dbf

• XBRL

• json

Flat File/Text Non-Text

Butuh

pendefinisian

saat impor
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• Cek Video

• Langsung Praktik
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1. Siapkan Data yang akan diimpor

2. Letakkan kursor pada salah satu

sel

3. Klik menu Data ➔ Get Data

4. Pilih From File ➔ From Text/CSV

5. Pilih File yang akan di impor

Import Text File
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• Cek Video

• Langsung Praktik
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1. Pilih beberapa parameter seperti

File Origin, Delimiter, Data Type 

Detection

2. Jika ingin melakukan perubahan

pada data pilih Transform Data

3. Jika data telah sesuai terbaca pilih

Load

Import Text File (Lanjutan)
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Beberapa Parameter yang perlu diperhatikan

• Delimiter => Fix Width, Jenis Delimiter

• Header => Ada di Baris keberapa

• Jenis Data => Text, Date, Numeric
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mdb

DISCLAIMER

• File Access versi lama yang dihasilkan dari Microsoft Access 2003 

tidak dapat dibuka di versi Access terbaru kecuali jika telah diinstall

mesin database yang sama (Microsoft Jet 4 OLE DB Provider).

Solusi:

• dibuka dengan Access 2003 atau Excel 2003

• Menggunakan aplikasi MDB Viewer Plus 
www.alexnolan.net/software/mdb_viewer_plus.htm
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dbf

DBF: dBase database file (dari database management system 

dBASE)

Cara Membuka:

1. Drag & Drop ke salah satu sheet

2. atau DBF Viewer Plus 

(www.alexnolan.net/software/dbf.htm)
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xBRL

Pada tahun 1998, Charles Hoffman, seorang CPA di Washington

menginvestigasi pemanfaatan XML (eXtensible Markup Language)

sebagai laporan keuangan elektronik.

Juli 1999, AICPA menyetujui pendanaan pengembangan XML tersebut. Proyek pengembangan

tersebut dinamai XFRML (eXtensible Financial Report Markup Language) 

Juli 2000, spesifikasi laporan keuangan elektronik pertama dari proyek tersebut di-release dengan 

nama XBRL (eXtensible Business Reporting Language) 
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xBRL : eXtensible Business Reporting Language merupakan bahasa berbasis XML yang 

menyediakan solusi yang efektif untuk persiapan, presentasi dan pertukaran Standar

Pelaporan Keuangan Internasional.

Cara Membuka:

1. Drag & Drop ke salah satu sheet

2. Data -> Get Data -> From File -> XML

Contoh data:

https://www.idx.co.id/perusahaan-tercatat/laporan-keuangan-dan-tahunan

xBRL
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• Cek Video

• Langsung Praktik
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1. Siapkan Data yang akan diimpor

2. Letakkan kursor pada salah satu

sel

3. Klik menu Data ➔ Get Data

4. Pilih From File ➔ From XML

5. Pilih File yang akan di impor

Import XML
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JSON

Contoh format data:

{name: "John", age: 31, city: "New York"}

Disclaimer:

• Dapat dibuka dengan Ms. Excel versi 2016 ke atas

• Untuk Ms. Excel 2010 dab 2013 harus mengunduh Power Query melalui web 

Microsoft (bit.ly/PQUERY2010)

• Cara lain bagi selain mengunduh Power Query, atau bagi yang menggunakan Ms. 

Excel selain yg disebutkan di atas dapat menggunakan converter:

• Offline. Misalnya SaveJson2CSV 

https://www.gunamoi.com.au/soft/savejson2csv/index.html

• Online. Misalnya https://www.convertcsv.com/json-to-csv.htm
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• Cek Video

• Langsung Praktik
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1. Siapkan Data yang akan diimpor

2. Letakkan kursor pada salah satu

sel

3. Klik menu Data ➔ Get Data

4. Pilih From File ➔ From JSON

5. Pilih File yang akan di impor

Import JSON
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Klik 
List

Hasil setelah 
klik list

JSON
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JSON

Klik 
To Table
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JSON
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JSON
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JSON

Klik 
Close & 

Load
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JSON

Jika ingin mengolah 
seperti file tabel 

Excel, klik Convert 
to Range



Testing Data Import Results
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A. Filter

You use filters to narrow down the population. You would filter for specific 

Object Codes or transactions above a certain materiality threshold.

B. Data Validation

Data validation in Excel allows you to set rules for what data is "allowed" in a 

cell. During the cleaning phase, you use validation to find anomalies.

C. Conditional Formatting

This is a visual technique to automate the discovery of outliers. It helps the 

auditor see patterns that a simple list of numbers cannot show.



Formula
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Fungsi Tujuan Audit

ISTEXT / ISNUMBER
Memastikan kolom saldo berisi angka, bukan teks

tersembunyi.

COUNTBLANK
Mengidentifikasi data yang hilang (misal: nomor faktur 

yang kosong).

VLOOKUP
Mencocokkan data transaksi dengan master data 

(misal: mencari harga fiktif).

ISNA / ISERR Menemukan anomali dalam relasi antar tabel.



Filtering
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• Cek Video

• Langsung Praktik
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1. Blok range data atau letakkan

kursor pada salah satu sel data

2. Klik menu Data ➔ Filter

3. Pilih kolom yang akan dilakukan

Filter

4. Filter akan menyesuaikan dengan

tipe data

1. Text

2. Number

3. Date
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• Cek Video

• Langsung Praktik
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1. Siapkan Kriteria

2. Blok range data atau letakkan

kursor pada salah satu sel data

3. Klik menu Data ➔ Advances

4. Pilih Area data sumber, Kriteria, 

dan Hasil Filter



Data Validation
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• Cek Video

• Langsung Praktik
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1. Pilih Sel

2. Blok range data atau letakkan

kursor pada salah satu sel data

3. Klik menu Data ➔ Data Validation

4. Pilih Data Validation…
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CUSTOM

• HANYA BOLEH DIISI ANGKA

• HARUS DIAWALI HURUF TERTENTU (ex: STA-xxx)

• HARUS DIISI NILAI YANG UNIK



Conditional 
Formating
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• Cek Video

• Langsung Praktik
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1. Pilih Sel

2. Blok range data atau letakkan

kursor pada salah satu sel data

3. Klik menu Home ➔ Conditional 

Fomating

4. Pilih New Rules…
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Latihan 

• Cari Pelanggan yang belum pernah melakukan transaksi

• Nomor Telp Pelanggan yang tidak valid 

• Jika sekarang tanggal 31 Maret 2020 Tandai transaksi yang 
umurnya lebih dari 30 hari



Ekspor Data



Audit Sistem Informasi

Ekspor Data

• Apabila terdapat keperluan untuk menyimpan data yang 
diolah/dikerjakan pada Ms. Excel dalam format selain *.xlsx

• Ekspor dapat dilakukan menggunakan fitur save as

• Ekspor data digunakan untuk Dokumentasi di Kertas Kerja
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• Cek Video

• Langsung Praktik

46

1. Pilih File > Save As.

2. Kotak dialog Save As akan muncul.

3.Pilih Lokasi tempat file akan disimpan lalu klik Save.

4.Pada Pilihan Save as type, Pilih format file yang 
tersedia.

1. Sebagai Contoh , klik Text (Tab 
delimited) atau CSV (Comma delimited).

2. Note: Perbedaan format menyebabkan
dukungan fitur-fitur yang berbeda . Untuk lebih
lengkap File format yang didukung di Excel.

5. Pilih Lokasi tempat file akan disimpan lalu klik Save.

6. Sebuah dialog Box akan muncul untuk
mengingatkan worksheet yang sedang aktif akan
disimpan dalam file baru. Jika ingin menyimpan
worksheet yang lain, buka worksheet tersebut lalu
lakukan Langkah seperti diatas. 

Export data (text file)

https://support.microsoft.com/en-us/office/file-formats-that-are-supported-in-excel-0943ff2c-6014-4e8d-aaea-b83d51d46247


Data Import Wars
Be the fastest group to successfully import, 
clean, and verify a "dirty" dataset.
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Data Import Wars

Rules of the Game:

1.The Hunt

In their respective groups, students must find or create 5 small datasets (e.g., procurement lists, 

payroll logs, or travel expenses) in different formats (.csv, .txt, .json).

2.The Sabotage

Groups should intentionally "pollute" their data with 3-5 errors (e.g., text in numeric fields, wrong 

date formats, or duplicate rows).

3.The Swap

The Teacher randomly reassigns these datasets to different groups.

4.The Battle

Groups must use Excel or a GAS tool to clean the data and provide the Record Count, Financial 

Total/Quantity Total.

5.Winning

The first group to present a verified, clean report that matches the "secret" key held by the original 

creators wins the round.
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https://forms.gle/K7YYMwsG5sdw1Zto9

Problem

Data Import Wars

https://forms.gle/KJBdELyrtqn1Uqmq5

Answer

https://forms.gle/KJBdELyrtqn1Uqmq5
https://forms.gle/KJBdELyrtqn1Uqmq5


Terima Kasih
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